Jump to content


Photo
- - - - -

How-to: Installing 4.6 under Plesk 7.1.x


  • Please log in to reply
5 replies to this topic

#1 brucew

brucew

    Soho Novice

  • Members
  • Pip
  • 5 posts

Posted 12 October 2004 - 01:19 AM

Worked through a couple of directory ownership issues with Mike on this one (Thanks, Mike!) and came up with this procedure that seems to work just fine.

Assumption: Domain has been created under Plesk and is functioning and resolving properly.

1. Create License Key
2. Create MySQL database (I did this in Plesk, you can choose the method you prefer.)
3. Upload (as root) soholaunch-pro-46-040315.tgz to /home/httpd/vhosts/<domainname.tld>/httpdocs/
4. SSH as root
5. cd /home/httpd/vhosts/<domainname.tld>/httpdocs/
6. tar -xzvf soholaunch-pro-46-040315.tgz
7. rm soholaunch-pro-46-040315.tgz
8. cd ..
9. chown apache.apache httpdocs (Make a note of the username first!)
10. Edit /home/httpd/vhosts/<domainname.tld>/conf/vhosts.conf as follows:

<Directory /home/httpd/vhosts/<domainname.tld>/httpdocs/>
php_admin_flag engine on
php_admin_flag register_globals on
php_admin_flag short_open_tag on
php_admin_flag safe_mode off
</Directory>

11. Restart Apache
12. Browse to http://www.<domainna...admin/index.php
13. Login as admin, admin
14. Verify URL and path data in left of screen.
15. Enter database name, database username and password in right of screen.
16. Submit
17. Cancel setup wizard
18. Logout of soholaunch
19. chown <username>.psaserv httpdocs
20. Logout of SSH session

This also works, with proper path adjustments, for subdomains created within the domain account using Plesk.

Kid-tested, mother-approved on:
RedHat 9
Plesk 7.1.2 and 7.1.4
PHP 4.3.8 and 4.3.9
MySQL 3.23.58 and 4.0.21
and survived upgrades between the noted versions.

Hope this helps!

#2 pcmedic

pcmedic

    Newbie

  • Members
  • Pip
  • 0 posts

Posted 20 January 2005 - 12:29 AM

I used the method stated and found out two things:

I am currently using a VPS and Plesk 7.5 cp an RPM install, and after following the descibed directions I probably chown httpdocs in the wrong area or something is different in 7.5 reloaded because now any new files created by the system still show up as apache.apache rights.

I have restored the httpdocs folders owner to the proper setting and converted all files back to the current user and owner but after using Soho new pages show up with apache.apache ownership again and then cannot finish the install because I do not have rights.

This error is affecting other domains on my server. I installed a fresh copy of sohoadmin to a different domain and ran install and found files with apach.apache ownership there too.

If anyone has a correction for this or what has happened to the httpdocs ownership at a vhosts level would be helpful.

I also my have found a quicker fix procedure than above and I'll post it for all users of Plesk after I resolve this issue and test a coulpe more installs. hopefully by the end of the day. I usually don't quit untill is it done.
PC Medic
Mobile Computer Services

#3 Guest_roboba_*

Guest_roboba_*
  • Guests

Posted 02 April 2010 - 06:17 AM

thanks for posting step by step configuration of installation. it makes installation very easy. thanks for sharing such a nice post.



#4 SureshMane

SureshMane

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 28 February 2011 - 07:05 PM

Hi All

Wanted to understand how we can install Soholaunch on a new site.

Earlier we were using this license on some other website and now we want to use this license for new website going to launch.

Looking forward to your earliest reply,
Thanks

Eydiya

#5 dresswell

dresswell

    Soho Dog

  • Administrators
  • 3,417 posts
  • LocationU.S.A.

Posted 28 February 2011 - 10:35 PM

You would change the licensed domain name in the partners area.
https://partner.soholaunch.com/
dresswell

 Free Soholaunch Hosting
Soholaunch Pro or Soholaunch Ultra Free with Hosting.
Check out our soholaunch hosting if your tried others

and were disappointed with your host or there support.
Get the help you need to build your website today.

Now offering a 99cent 1st. month Trial Offer.
Easy Website Maker


#6 ednablue27

ednablue27

    Soho Novice

  • Members
  • Pip
  • 1 posts

Posted 25 May 2011 - 01:00 PM

in glad to be here.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users