Jump to content


- - - - -

SEO Friendly Pages in 4.9.3r20 in text editor


  • Please log in to reply
12 replies to this topic

#1 Guest_crapouti_*

Guest_crapouti_*
  • Guests

Posted 24 January 2009 - 04:20 AM

I just upgraded to 4.9.3r20. To enable SEO friendly urls I clicked:

Webmaster... Search Engine Ranking... Replace menu links to "Home_Page" with domain root url? YES

But after reloading my pages, the menus still showed the index.php?pr= everywhere. I had to edit the menus (move one item in and out) in order for it to work with the menus.

However, I could not find where in the text editor link to activate it.

#2 kyle04

kyle04

    Senior Member

  • Moderators
  • 411 posts

Posted 24 January 2009 - 10:09 PM

Try the (free) sso plugin by lwyau.


AndyP

#3 Guest_crapouti_*

Guest_crapouti_*
  • Guests

Posted 25 January 2009 - 04:33 AM

AndyP, are you talking about this?
http://addons.sohola..._navigation/url

#4 kmakpres

kmakpres

    Senior Member

  • Members
  • 116 posts

Posted 25 January 2009 - 04:49 AM

I don't think you have to activate anything. All the pages I have built have the url.page name.php extension on them. Not sure what happens if you had an earlier build and updated tho.

The option you refer to here

Webmaster... Search Engine Ranking... Replace menu links to "Home_Page" with domain root url? YES

doesnt physically change anything it just directs the links in your site back to the root url and not the "home page" according to the help button.

In the menu navigation do you have the SEO Friendly links button clicked to yes?

Edited by kmakpres, 25 January 2009 - 08:40 PM.
menu nav

Thanks, Dan

 


#5 trafalga21

trafalga21

    Soho Novice

  • Members
  • Pip
  • 6 posts

Posted 30 January 2011 - 01:38 AM

I am having the same problem. I have turned on SEO links and Chagne HomePage to Yes. Every time I click on my "Home Page" button the URL includes Home_Page.php

The template I am using has a custom pgm-auto_menu.php as part of it. I believe it is only changing how the menu's are displayed i.e. the look and feel. I have skimmed the code but nothing is jumping out at me as to where it might be fixable. (I don't know php, but am a developer).

I have also removed Home Page from the menu system and readded it. No change.

Thanks for any help on this!
Adam

#6 dresswell

dresswell

    Soho Dog

  • Administrators
  • 3,417 posts
  • LocationU.S.A.

Posted 30 January 2011 - 02:45 AM

Updating your soholaunch to the latest build should fix that.
Click on the little dot lower right conner of your sohoadmin.
dresswell

 Free Soholaunch Hosting
Soholaunch Pro or Soholaunch Ultra Free with Hosting.
Check out our soholaunch hosting if your tried others

and were disappointed with your host or there support.
Get the help you need to build your website today.

Now offering a 99cent 1st. month Trial Offer.
Easy Website Maker


#7 trafalga21

trafalga21

    Soho Novice

  • Members
  • Pip
  • 6 posts

Posted 30 January 2011 - 03:01 AM

did that a week ago. 4.9.3r44 latest stable build. should I install r46?

#8 dresswell

dresswell

    Soho Dog

  • Administrators
  • 3,417 posts
  • LocationU.S.A.

Posted 30 January 2011 - 04:10 AM

Without the search engine friendly the page link would be index.php?pr=Page_Name.
With search engine friendly on Page_Name.php.
This makes the auto menu system and text editor link do just that: generating hyperlinks to pages with the Page_Name.php format.
dresswell

 Free Soholaunch Hosting
Soholaunch Pro or Soholaunch Ultra Free with Hosting.
Check out our soholaunch hosting if your tried others

and were disappointed with your host or there support.
Get the help you need to build your website today.

Now offering a 99cent 1st. month Trial Offer.
Easy Website Maker


#9 trafalga21

trafalga21

    Soho Novice

  • Members
  • Pip
  • 6 posts

Posted 30 January 2011 - 02:35 PM

OK - Then the SEO friendly links is working. I am getting page names for all my pages.

I don't think the other option is working. When i goto Admin console -> webmaster -> Search Engine Ranking. There is an option at the bottom "Replace menu links to "Home_Page" with domain root url". Per the Doc's this should replace any menu calls to "Home_Page" with the root URL. This is not working.

My original thought for why it isn't working is because the template I am using has a modified pgm-auto_menu.php. I believe it is just modified to make the menus look pretty per css and the template, but thought that it could be missing something related to this option.

I will see if I can find an original copy of the .php file and do a diff on them and see if I can find anything.

Thanks - Adam

p.s. - sorry if my first post wasn't clear about this issue.

#10 trafalga21

trafalga21

    Soho Novice

  • Members
  • Pip
  • 6 posts

Posted 30 January 2011 - 02:59 PM

OK - did the diff on those two files and i believe I found the issue. The custom file has the home_page change code cut out of it. I tried to put it back in, but then nothing rendered on the site.

I will keep working on this and post something back after I figure it out.

Should I let the template designer know about this?

#11 dresswell

dresswell

    Soho Dog

  • Administrators
  • 3,417 posts
  • LocationU.S.A.

Posted 30 January 2011 - 03:14 PM

Post the url of the site so we can take a look.
dresswell

 Free Soholaunch Hosting
Soholaunch Pro or Soholaunch Ultra Free with Hosting.
Check out our soholaunch hosting if your tried others

and were disappointed with your host or there support.
Get the help you need to build your website today.

Now offering a 99cent 1st. month Trial Offer.
Easy Website Maker


#12 trafalga21

trafalga21

    Soho Novice

  • Members
  • Pip
  • 6 posts

Posted 30 January 2011 - 03:38 PM

first time i posted url it needs to be reviewed by mods. it is w cubed dot indyrange dot org

#13 trafalga21

trafalga21

    Soho Novice

  • Members
  • Pip
  • 6 posts

Posted 30 January 2011 - 04:15 PM

Fixed it! Finally - Fing case sensitivity struck again.

while i was working on the code somehow I "uppercased" all the variables and they were not working. Finally realized that and lo and behold stuff started working!

going to send the code to the template owner - maybe it will help him out.

Well my first foray into php was fun!

Thanks for the Help and comments! Writing asp during the day is a lot different than HTML and php.

Adam




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users