Jump to content


Photo
- - - - -

Template not in format


  • Please log in to reply
6 replies to this topic

#1 crow-hill-guy

crow-hill-guy

    Member

  • Members
  • PipPip
  • 18 posts

Posted 03 January 2009 - 08:38 PM

Designed a custom template, zipped, and uploaded but couldn't use it because of error saying "This template does not seem to be in format."

3 Days reading posts for suggestions plus lots of reading suggested articles. Then went back to basics with Jaun-Vincent Haasbroek. After much frustration, decided to take the Blink123 set from his Zip and uploaded as is - guess what? It worked just fine and I was able to apply the template without errors!

Built a replica of Blink123 (copied all his gifs) using FW-8 and exported images as jpg (in root) then did his suggested edits using DW-8. DW came up with 3 error lines (doesn't like the "background" parameter that Jaun says to put with Index-07, Index_10, and Index_18) so I removed the "background" parameter and DW was happy. Ran code through WC3 and got no errors there either. Retained the original .css from Jaun, ran it through WC3 and came back no errors too.

Zipped my template package, uploaded, and when I select my new template, get same error - "This template does not seem to be in format."

Printed copies of both sets of html (Index.html) and compared but don't see anything that would give me a hint where the problem is.

I'm sure I'm doing something stupid but can't put my finger on it. My site currently has both templates (Juan's and mine) on it and I am using a "stock" template for the time being. The site is not in production yet (obvious reasons) and I can tinker as much as needed. I just don't know where I'm going wrong!

Sure could use some help..:confused:

#2 dresswell

dresswell

    Soho Dog

  • Administrators
  • 3,411 posts
  • LocationU.S.A.

Posted 03 January 2009 - 08:57 PM

Welcome to the soho fourms crow-hill-guy,
What is the name of your templet?
Is it in 3 parts like your user name here?
dresswell

 Free Soholaunch Hosting
Soholaunch Pro or Soholaunch Ultra Free with Hosting.
Check out our soholaunch hosting if your tried others

and were disappointed with your host or there support.
Get the help you need to build your website today.

Now offering a 99cent 1st. month Trial Offer.
Easy Website Maker


#3 crow-hill-guy

crow-hill-guy

    Member

  • Members
  • PipPip
  • 18 posts

Posted 03 January 2009 - 09:25 PM

I used these 2 names:

LSWB-Blink123-Original
LSWB-Blink123-Bob_Lewis

#4 jaxpa

jaxpa

    Advanced Member

  • Moderators
  • 56 posts

Posted 04 January 2009 - 09:29 PM

Hi,

I have generally found if you get that error then the main index.html page is missing the #CONTENT# variable

The other possibility(not 100% sure though) is that you may need to name the index.html page to a lower case 'i' as I know that some servers/code can sometimes be case sensitive.

#5 crow-hill-guy

crow-hill-guy

    Member

  • Members
  • PipPip
  • 18 posts

Posted 04 January 2009 - 10:15 PM

You nailed it!

My Index.html was fine when I renamed it to index.html - just a small issue with the "screenshot.jpg" but I can sort that one (at least I have confidence).

That was definitely not something I was looking for - like I said, it was probably something stupid and it was.

Lesson learned: "Never over-look the obvious"!;)

#6 draknet

draknet

    Senior Member

  • Moderators
  • 828 posts

Posted 06 January 2009 - 06:02 AM

On servers, capitalization in both file and directory names is important. To a Unix server (dunno about Windows because I don't touch them with a ten foot pole), all the following files:

Index.html
index.html
iNdex.html
index.htmL

are all different files. A good rule of thumb to follow when working with servers is:

- alphanumeric
- dashes
- underscores

only. No spaces, no extended characters, no nothing. Generally, things should always be lowercase.

DrakNet Web Hosting | (Or just me: jenlepp.com | Twitter: @jenlepp)
Please note that DrakNet no longer offers licensed Soholaunch as of 9/1/2010 - if you are looking at an old forum post that recommends us as a Soholaunch host, please note that situation has changed since the post was made.


#7 crow-hill-guy

crow-hill-guy

    Member

  • Members
  • PipPip
  • 18 posts

Posted 06 January 2009 - 03:42 PM

Right you are, Draknet. I had to learn the hard way as it took a while to figure out that my Screenshot.jpg wasn't loading in the Template selections (only seeing a red x) because it should have been named screenshot.jpg and when I changed, all was working just fine!

At last, Juan's comment that making templates is "simple" is a little easier to believe. As long as we have some decent Image editing software, the capability to "slice" an image, and a good wysiwyg html editor, we are off to the races and that's me (finally!). Hard to believe that I have been tinkering around with this for about a year and only now have a complete revelation!

My thanks to all who assisted (online and offline). One day, I hope to be able to return the favour!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users