Jump to content


Photo
- - - - -

FAQ: File upload problems


  • Please log in to reply
22 replies to this topic

#1 Mike Morrison

Mike Morrison

    Administrator

  • Administrators
  • 10 posts

Posted 04 March 2005 - 12:07 AM

Problem: Cannot upload [insert file type here] files.

When you try to upload a file, here's what the product does:
1. Determine file type
2. Verify that file type is acceptable, otherwise show "File is not an accepted format..." error.
3. Copy file to appropriate folder (/images or /media). Show "System Error" if unable to copy.

"File is not an accepted format..." next to the file name...
The File Upload feature checks each uploaded file against a hard-coded 'white list' of file types/extensions. If a file's type/extension is not explicitly defined on this list it is rejected in the interest of end-user error prevention as well as security. This list is meant to be updated as new standards and technologies become popular. If you're encountering this error when trying to upload a certain type, check to see whether we're aware of it. As long as the file type is gennerally considered a 'safe' type (i.e. .wma, .mp3), we'll usually work it in to our next bulid.

"System Error!" next to the file name...
You're dealing with some sort of permissions or ownership problem with the 'images' and/or the 'media' folder.

First step is to check that permissions on 'images' and/or 'media' are set no tighter than 755.

If that doesn't do the trick, check that the owner and group settings for 'images' and/or 'media' are correct. If you're unsure what to use for user and group, the safe bets are typically 'apache.apache' if phpsuexec is disabled or 'nobody.nobody' if phpsuexec is enabled.

#2 sharanx

sharanx

    Member

  • Members
  • PipPip
  • 19 posts

Posted 21 December 2005 - 02:33 AM

What if the file permissions cannot be changed? I have tried changing the file permissions for the media folder, but it just doesn't seem to take effect!

#3 Ruben

Ruben

    www.Sohotemplates.com

  • Moderators
  • 584 posts

Posted 21 December 2005 - 11:46 PM

then you should contact your host i guess.
Ruben
Visit www.sohotemplates.com for your Soholaunch templates
High Quality StockPhoto's ! www.microstockphoto.com
Looking for High Quality Flash files? check Flashden!

#4 Ryan09

Ryan09

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 14 April 2006 - 05:16 PM

I am getting this error.

Error: Unable to save template Files...
Possible Solution: chmod the /sohoadmin/program/modules/site_templates/pages directory to 777

What should I do?

#5 Ryan09

Ryan09

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 15 April 2006 - 04:27 PM

can someone please help me with this

#6 lwyau

lwyau

    a soho enthusiast

  • Moderators
  • 5,605 posts

Posted 15 April 2006 - 04:44 PM

Change the permission to that folder (better yet, /sohoadmin and all sub-directories within it) to 777. If you cannot change it, contact your host to do it for you, just as Ruben indicated.

#7 Ryan09

Ryan09

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 16 April 2006 - 05:03 PM

ok thanks!! one question...where would i be able to change it?

#8 lwyau

lwyau

    a soho enthusiast

  • Moderators
  • 5,605 posts

Posted 16 April 2006 - 09:06 PM

Go to cpanel, file manager.

#9 Ryan09

Ryan09

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 17 April 2006 - 02:26 AM

ok thanks...i tried to change it but when i put it at 777 i hit change and nothing happened so i will have to have my host change it...thanks

#10 NumberSix

NumberSix

    Member

  • Members
  • PipPip
  • 22 posts

Posted 03 June 2006 - 12:22 AM

Just a thought on changing permissions to 777. From a security standpoint, this seems like a VERY BAD IDEA. Doing this would give anybody who has Internet access the ability to change your files, which is probably not what is intended. I have my site running with permissions set to 755, and everything seems to function just fine.

Also note that on images, for whatever reason soholaunch will not upload image files with capitol extensions - image.jpg is fine, but image.JPG is not. So make sure that file extensions are typed in lower case.

#11 blazin202

blazin202

    Member

  • Members
  • PipPip
  • 25 posts

Posted 20 January 2008 - 05:05 AM

hi,

Is this file upload problem related to issues with uploading images via upload file option on Forms ?

I have only been able to upload a picture via form once out of maybe 20 trys- ??? Any solutions to getting it to work consistently?? I have tried various sizes and file types - .jpg - .gif and sizes from 3kb to 120kb -

I get no error messages - form submits all fields to the table but leaves empty auto_image ?

#12 dresswell

dresswell

    Soho Dog

  • Administrators
  • 3,360 posts
  • LocationU.S.A.

Posted 20 January 2008 - 01:42 PM

blazin202,
What soho verison are you running.
There are a few bugs in the form area.
I have found some workarounds.
dresswell

 Free Soholaunch Hosting
Soholaunch Pro or Soholaunch Ultra Free with Hosting.
Check out our soholaunch hosting if your tried others

and were disappointed with your host or there support.
Get the help you need to build your website today.

Now offering a 99cent 1st. month Trial Offer.
Easy Website Maker


#13 lwyau

lwyau

    a soho enthusiast

  • Moderators
  • 5,605 posts

Posted 20 January 2008 - 01:53 PM

hi,

Is this file upload problem related to issues with uploading images via upload file option on Forms ?

I have only been able to upload a picture via form once out of maybe 20 trys- ??? Any solutions to getting it to work consistently?? I have tried various sizes and file types - .jpg - .gif and sizes from 3kb to 120kb -

I get no error messages - form submits all fields to the table but leaves empty auto_image ?

The file upload file option makes the file an attachment to the email sent to the site owner. It does not make the image file name in the auto_image field of the table.

#14 blazin202

blazin202

    Member

  • Members
  • PipPip
  • 25 posts

Posted 20 January 2008 - 07:02 PM

Dresswell - I am running - v4.91 r7


Lwyau - I been messing around with it for a few days and I do have like 2 emails with pic attachments but most of the times I tried the pic never showed anywhere yet the record with other fields shows in the table - I did have one picture show in the table directly from the file upload field -

*New - Last night I figured out If the user (that created the record) re-uploads the picture using the file upload -- IT WORKS so far 100% of the time or gives you an error as to why (file to large or wrong file format) and the pic record shows in the auto_image field in the table (well the file name) - pic goes to the image folder -

Seems like a little bug? Does it make sense to anyone?

#15 dresswell

dresswell

    Soho Dog

  • Administrators
  • 3,360 posts
  • LocationU.S.A.

Posted 20 January 2008 - 07:18 PM

The curent verision is v4.9.2 r17
And this could be part of your problem.
Check this post before you update #21
http://forum.soholau...17603#post17603

 Free Soholaunch Hosting
Soholaunch Pro or Soholaunch Ultra Free with Hosting.
Check out our soholaunch hosting if your tried others

and were disappointed with your host or there support.
Get the help you need to build your website today.

Now offering a 99cent 1st. month Trial Offer.
Easy Website Maker


#16 blazin202

blazin202

    Member

  • Members
  • PipPip
  • 25 posts

Posted 20 January 2008 - 10:17 PM

Dresswell - thanks for the input - (I just installed this 2 weeks ago - assumed i had the latest)

I installed the newest version - The image/file upload problem still exists (no change) - I did Logout fully - closed browser everything - no change ? I noticed no mention of that "fix" in update notes ? Still potential bug that should be addressed ?


Also - I noticed the format time stamp in table option - There is no US standard - 01/20/08 or mm/dd/yy or mm/dd/yyyy ? Anyone have an ideas on that matter ?

#17 dresswell

dresswell

    Soho Dog

  • Administrators
  • 3,360 posts
  • LocationU.S.A.

Posted 21 January 2008 - 01:52 AM

I have seen this problem pop up lately.
It seams to update to the latest verision.
Is says v4.9.2 r17
Everything seams to work fine for a while.
Then you cant save things,some things wont open,etc.
To see if this is your problem go to your sohoadmin>
data base manager>system tables.
If theres nothing there this is your problem.
Now you would like to know how to fix it.
Well i got that info to.
Thanks to some of the members here.
First do a backup and save to your pc.
Then delete it from your sohoadmin.
Now you want to do an update.
I know you already have v4.9.2 r17
Just bear with me.
If your host is running phpsuexec you should be
fine to update. if not you will want to go to
Webmaster > Software Updates >
Technical diagnostic info (for Geeks)
There you will see if you are running phpsuexec.
If you are, then go and update.
If not check yes to
chmod to 777 before updating?
Log out and back in after update.
Now go to help>dionastic>check your permissions
and setting are all ok.
Then go to your database and see if there any files under
system tables.
Another bugz crushed.
Just dont ask me where it came from.
dresswell

 Free Soholaunch Hosting
Soholaunch Pro or Soholaunch Ultra Free with Hosting.
Check out our soholaunch hosting if your tried others

and were disappointed with your host or there support.
Get the help you need to build your website today.

Now offering a 99cent 1st. month Trial Offer.
Easy Website Maker


#18 obama5493

obama5493

    Soho Novice

  • Members
  • Pip
  • 1 posts

Posted 09 March 2011 - 07:38 AM

Just a thought on changing permissions to 777. From a security standpoint, this seems like a VERY BAD IDEA. Doing this would give anybody who has Internet access the ability to change your files, which is probably not what is intended. I have my site running with permissions set to 755, and everything seems to function just fine.

Also note that on images, for whatever reason soholaunch will not upload image files with capitol extensions - image.jpg is fine, but image.JPG is not. So make sure that file extensions are typed in lower case.


ok thanks...i tried to change it but when i put it at 777 i hit change and nothing happened so i will have to have my host change it..



____________________

#19 dresswell

dresswell

    Soho Dog

  • Administrators
  • 3,360 posts
  • LocationU.S.A.

Posted 09 March 2011 - 02:44 PM

It would help if you had a soholaunch site.
And not just looking for an inbound link like a spammer.

 Free Soholaunch Hosting
Soholaunch Pro or Soholaunch Ultra Free with Hosting.
Check out our soholaunch hosting if your tried others

and were disappointed with your host or there support.
Get the help you need to build your website today.

Now offering a 99cent 1st. month Trial Offer.
Easy Website Maker


#20 webinxs22

webinxs22

    Member

  • Members
  • PipPip
  • 11 posts

Posted 10 May 2011 - 11:25 AM

Go to cpanel, file manager and change file type.

Man and Van, Man with Van, Removal Company, London Removals





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users